Linux parameters

Hello there!

Today let’s talk about how to install MicroStrategy in Linux.

When you read the documentation, you see that it requires some changes in Linux parameters to install and run MicroStrategy correctly.

If you don’t change those parameters, you can get some errors like:

WARNING: maximum number of semaphore arrays 128 is low; please increase to 2048 or greater to use high performance share memory IPC.

Just execute this command below in a terminal to setup your environment:

echo 'kernel.sem = 250 32000 100 2048' >> /etc/sysctl.conf;echo 'kernel.shmmni = 4096' >> /etc/sysctl.conf;sysctl -p /etc/sysctl.conf;/sbin/sysctl -w vm.max_map_count=5242880

If you want, I have created a shell script file for bash that you can execute and do it for you:

install_mstr_parameters

Just download it, unzip and give permission to execute to the .sh (chmod +x install_mstr_parameters.sh).

Execute using this command:

./install_mstr_parameters.sh

That’s it.

Hope it helps.

 

God bless you.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s